Page 1 of 3

Frog Juicers - Light Loco Problem

Posted: Fri Mar 27, 2020 5:02 pm
by Dad-1
I've included this here, but it may be applicable to DC, as all my Locos are DCC I've
entered in the DCC threads.
I'm in the process of making a inglenook shunting layout with two points, both to be
operated by mechanical hand operated rods. Rather than rely on point blade contact
for frog polarity on live frog points I've fitted two Gaugemaster solenoid operated high
speed switches.
The problem is when using a Hornby Sentinel 0-4-0, this begins a stutter as it comes across
the rail joints at either end of the switched section (switch rail & Frog). It ticks and lurches
until it gets over the joint (mostly I don't allow it to run without a push).
Heavier locomotives in the form of a Bachmann Midland 1F, and a Bachmann 57XX have no
trouble at all. I did try running the Sentinel at a speed somewhat higher than one would
use on very tight length shunting tracks and it passed over without problems.
Could it be that the Sentinel is too light, not enough resistance ?
The frog juicers do have a few inches of wire between the points and switch - say 12", could
this be some of the problem ?
All track is fitted with droppers that are attached onto copper-clad tags at the back of the
board. It's been run on both a Hornby Select & Gaugemaster DCC system, neither unit has
a fit and cuts-out !!

The easy way is not to bother with the Sentinel, but it's the ideal traction, very short and
powerful enough to haul the maximum loading of 6 wagons (with slight braking for Kadees).

Looking for ideas to solve ?

Geoff T.

Re: Frog Juicers - Light Loco Problem

Posted: Fri Mar 27, 2020 5:52 pm
by Bigmet
Dad-1 wrote:...It's been run on both a Hornby Select & Gaugemaster DCC system, neither unit has a fit and cuts-out ...

I suggest that as the systems are not tripping there's not a problem with the track supply switching, and it is our old friend inadequate pick up continuity on the loco. All rigid four wheelers run with only 3 wheels making contact with the rails on track that is anything other than perfectly plane. Most RTL points come with an upward bow, caused by hysteresis in the curved rails, and what will happen with a four wheeler is that diametrically opposite wheels either side maintain rail contact while the vehicle rocks on the bowed rails see-sawing contact between the other diametrically opposite pair: in contact side A - neither in contact - in contact side B.

My first shot at a solution would be forming the pick up wipers for much greater contact pressure on the wheelback. (I have soldered nickel silver handrail wire stiffeners on some of the floppier Hornby pick up wiper designs, to make them do the job right...)

Re: Frog Juicers - Light Loco Problem

Posted: Fri Mar 27, 2020 8:31 pm
by Dad-1
Thanks for that idea Bigmet.
Nothing to loose, I may also see what if any difference
balancing as much weight as I can on it. Not practical
for use, but will interesting.

Geoff T.

Re: Frog Juicers - Light Loco Problem

Posted: Fri Mar 27, 2020 9:17 pm
by heda
I understand the problem with 'rigid 4 wheel loco's'. So do they have to be rigid, I have been thinking why not open up the the hole in the chassis of the non driving axle slightly to allow it some slack and keep all 4 wheels on the rails. And if it is that easy why don't Hornby do it ?
Dave

Re: Frog Juicers - Light Loco Problem

Posted: Fri Mar 27, 2020 9:32 pm
by Bigmet
The principle is simple enough, but with just two axles can easily lead to a model that 'wobbles about' as it runs. No experience of my own to offer, as I have never built an 0-4-0 mechanism.

Re: Frog Juicers - Light Loco Problem

Posted: Fri Mar 27, 2020 10:47 pm
by Bufferstop
Geoff, it's almost certainly down to the Sentinel's combination of small wheels low weight and low current consumption. It just isn't pulling enough current for the frog juicer to spot it and switch. That's why it stutters. My approach would be that the frog juicer is overkill for mechanically operated points. A microswitch with a long actuator, operated by the end of the rod, or a block attached somewhere on the rod would change the polarity for sure, before the loco got there.

Re: Frog Juicers - Light Loco Problem

Posted: Sat Mar 28, 2020 11:27 am
by Dad-1
Well a small amount of time checking this morning has proved that Bigmet's idea is not
the cause.
So what DO we know.
A) the track work is all connected correctly. Even when the decoders have been 'upset' there is no short circuit.
B) The frog juicers do operate as you can hear the solenoid click on changes.
C) The decoders are why the locos click/jerk/stall as they are between track pick-ups (that are fine) and the driving decoder
D) 3 different locos have had trouble this morning, trusty 06 'Marilyn' 0-4-0, The Sentinel 0-4-0 and a Bachmann Junior 0-6-0
E) two different digital sets have the same problem, proving to me it's nothing to do with control systems.
F) in the 3 locos tested this morning there were 2 different decoders. 2 are Hornby, a 4 pin and 8 pin version, plus an Ebay type unknown.
G) the locomotives work fine with no problems on other layouts so no serious decoder defects, or concerns.

H) the problem IS from the frog switching system - BUT WHY ??

We are going to remove wires from one frog juicer and put through a two way manual switch. If this works I'll probably split the track
with insulated rail joiners between the two points to separate the rails while leaving the power bus still intact.

Just as I came in to write this it started behaving correctly - could the frog juicers not like colder temperatures of a garage ?
It should be well inside their working range.

All I know is there MUST be some form of feedback, somewhere that decoders don't like !!

I could try using Zephyr Express, Zephyr DCS50, Bachmann Dynamis, I do have things to substitute and swap, but this one is really
getting to me !!

Geoff T.

Re: Frog Juicers - Light Loco Problem

Posted: Sat Mar 28, 2020 11:54 am
by Mike Parkes
First thing to check is that those locos have their pick upscorrectly aligned,

Re: Frog Juicers - Light Loco Problem

Posted: Sat Mar 28, 2020 12:47 pm
by Dad-1
Mike Parkes,

The pick ups are fine, these are sorted out well in advance on all my locos. Something
like 6 different locos being used during this fault finding exercise. Namely Bachmann
Junior 0-6-0, Midland 1F, 57XX plus Hornby sentinel, 06, Jinty.

Ahh Bufferstop this is meant to be a bullet proof "Club" shunting layout. I can't use the
Clubs Heljan GWR 1361 as that is 'Locked In' the Clubs village hall cellar although this is
planned to be the normal single loco in steam. Here I thought (Always a mistake) frog
juicers would be less for them to wreck when taking to exhibitions.

I have found an interesting situation.
When another locomotive is sitting on the tracks the problem vanishes, at least on the
testing I've done since finding this out. The additional locomotive is not having the motor
driven, just sitting there with obviously it's decoder collecting a miniscule amount of
power while awaiting instructions.
This MUST have a resistance ?
Will adding some form of resistance to the underboard Bus provide the smoothing required ?
Could this be achieved by adding a capacitor ?

Brian's experience & knowledge needed here methinks.

I've done a video of the ticking loco, but not uploaded via YouTube yet.

Geoff T.

Re: Frog Juicers - Light Loco Problem

Posted: Sat Mar 28, 2020 12:56 pm
by Bufferstop
If the frog juicer switches OK for other locos, it can only really be that it's failing to react to the short circuit caused by that loco. The polarity switching is accomplished by spotting the short circuit before the DCC power supply does, and reversing the polarity. My guess would be that a light loco with small wheels isn't a good enough short circuit, I've seen similar behaviour running a small loco over the IRJ trying to approach a wrongly set point. I asked about this the first time I saw a reverse loop module (which does the same thing). I wasn't convinced by the demonstrators assurance that it would always operate before the supply tripped. It will probably get worse each time you try it, as it will be the tip of the pickup that takes the punishment every time, whilst the wheels will offer a clean contact most times. I come back to saying if you want to use little 0-4-0s use a switch. I bet 0-4-0s with larger wheels won't suffer the same problem. We kid ourselves that the wheels offer the same point contact no matter what diameter, run them in the dark you might be able to see the little wedge of conductive air behind the point of contact as the larger wheel rolls.

Re: Frog Juicers - Light Loco Problem

Posted: Sat Mar 28, 2020 2:43 pm
by Dad-1
Hi Bufferstop,

It switches O.K, if it didn't switch the DCC control system would sense a short and cut-out.
The wheel size doesn't make any difference, while the Sentinel has small wheels, when I
tried Marilyn the effect was the same, as it was also with the Bachmann Junior 0-6-0.

The interaction of two Frog Juicers is causing some disruption in the signals being carried
by the rails to the locomotive fitted decoders. The rails are switched to the right polarity,
but not carrying clean signals for the decoders. Exactly where and how the signal disruption
is happening is beyond me - HOWEVER, when another DCC fitted locomotive is sitting anywhere
on the live tracks (Being DCC they are all live all the time) there is no signal problem and
as a result even the shortest wheelbase locomotives run exactly as it should.

With my level of electronics understanding I don't know how adding frog juicers, that are
working, can possibly corrupt the messages supplied to a running locomotive, but only as
they are within one of the two switched zones, one for each point. It must be some form
of feed-back, but not a controller recognised short-circuit.

I think that it'll need someone with Flashbangs expertise to offer a suitable solution. Do you
recall that at one time some recommended Terminators should be fitted on DCC layouts. The
reasons escapes me now. Whatever they were may be capable of solving my problem.

Geoff T

Re: Frog Juicers - Light Loco Problem

Posted: Sat Mar 28, 2020 3:19 pm
by Bufferstop
Ah, I typed my last response at the same time as you were typing. Bit more to go on. I think this may be a case of needing a bit of load to absorb the spike caused by reversing the load at the frog, there's a well established name for it a "quench". Your extra loco sitting there awaiting a command is putting a small load on the supply which seems to be doing the job for you. When the supply to the frog reverse there is a decoder connected to the rails being switched, it won't be a pure resistive load so it will send a spike back down the supply, a quench would help absorb it. A couple of 12V bulbs in series across the rails might do the job.

Re: Frog Juicers - Light Loco Problem

Posted: Sat Mar 28, 2020 3:41 pm
by Dad-1
Life is a Fog, and so is my video.
I hope it at least shows (Very Roughly) what the signal corruption is doing.

https://youtu.be/cUGSBiKCaTY

Geoff T.

Re: Frog Juicers - Light Loco Problem

Posted: Sat Mar 28, 2020 4:31 pm
by Roger (RJ)
Try putting power feeds to that very short length of track, see what happens.

Re: Frog Juicers - Light Loco Problem

Posted: Sat Mar 28, 2020 5:19 pm
by Dad-1
Hi Roger (RJ),

Already has it's own Bus connections, shortest one I've ever had. Not measured, but
think it's little over 25 mm !
So long as I keep another loco parked somewhere I get no problem. For the cost I'm
looking at a DCC Supplies 'Terminator' thingy which is supposed to dampen out any
spike from shorts that are naturally produced by operating the juicers.

I have contemplated lifting track and as that short length connects the two points
replacing with 4 insulated joiners - one at every rail connection. This would mean
that any spikes produced at each point point would have to link back through the
Bus rather than so directly through 25 mm of track ?

I know corrupting decoder messages is easier than many of us may believe. I recall
when cleaning tracks after long storage I had a 57XX running along cleaned track
onto uncleaned sections. The loco stuttered and then managed to reverse it's direction
of travel without any output changes from the controller !!

At least this is something to occupy my mind when stuck at home.

Geoff T.