CV settings/loco not responding

Post all your DCC only problems, solutions and discoverys here.
FergusK
Posts: 21
Joined: Thu May 26, 2016 11:09 am

CV settings/loco not responding

Postby FergusK » Fri Jul 05, 2019 9:21 am

Hi all,

Yesterday, I inadverently caused all locos on my track to have the same CV number. I had two locos that would not respond and I was trying to get them to work, when I done something to give all locos the same default number.

I've tried almost everything yesterday to try and fix what I done, but I can't seem to do anything right! When I place a loco on the track, it has a Library number default of 3 (Multimaus controller) and the loco runs. When I change the library number to another number, say 1, I then go to the CV option and change that to 1 as well (this worked for me before) for that individual loco. The loco does not respond.

I have only one loco on the track each time I try this, but I managed to get one loco to respond to another library number of 1, but no matter what CV number I give it, it still runs.

A side issue - when I place another loco on the track (on its own) with the default library setting of 3 - the front headlights come on, when the train is going in the opposite direction...

Any advice/ideas as to what to do!!??
Thanks
Fergus

Bigmet
Posts: 7128
Joined: Tue Aug 14, 2007 2:19 pm

Re: CV settings/loco not responding

Postby Bigmet » Fri Jul 05, 2019 10:15 am

If I read this correctly, all the decoders are now on 'factory default' address (library number) 3? That would imply that you issued a decoder reset command that was effective on all the decoders that were then on track supply.

I don't know the 'multimaus' system at all, but here's what I would suggest.
Reread the manual to make sure you are following the correct procedure.
Does the multimaus system have a reset provision? If it does, reset the system. (You may have to look online for this information; my first LENZ system manual didn't describe the system reset procedure for example.)
Then one loco at a time on track, perform a decoder reset. Then attempt address programming that decoder, following the system instructions and test to see if the decoder then runs on the address you want.

Don't worry about the 'wrong end' lights illuminating for now, you first need to obtain control of addressing. Once you have normal programming restored, that will be a snap to fix by a change to CV29.

FergusK
Posts: 21
Joined: Thu May 26, 2016 11:09 am

Re: CV settings/loco not responding

Postby FergusK » Fri Jul 05, 2019 11:51 am

Hi,
I done a full reset- but when the controller still retained the loco I had tried to reset.. I've read the manual, but maybe I'm reading things wrong. No matter what I try, each loco seems to work only on library no. 3

I'll keep trying! Thanks

User avatar
Flashbang
Posts: 3434
Joined: Thu Oct 18, 2007 1:07 pm
Location: SE United Kingdom
Contact:

Re: CV settings/loco not responding

Postby Flashbang » Fri Jul 05, 2019 12:50 pm

Hi

I would place each loco in turn onto an isolated Programming track and do a reset of each locos decoder - Normally CV8 enter 8 but check the decoder manual as some use a different CV for the reset. This will ensure everything on the decoder is restored back to manufacturers default settings. Including address number to 3.
Next, once the reset has been proved - by checking it moves on the Main lines under address 3 and lights etc all work. Section 2.2 of the manual. Note: You can not normally do this on the Programming track only on the main where a console has a dedicated Programming output feed pair of wires. If the MultiMAUS doesnt have a dedicated Programming output pair of connections, still use a separate isolated section of track for all programming and either use a DPDT Centre Off switch to select which rails the MM feeds - Main or Programming or move the two rail feed wires from the main to the programming track. An example of basic switching is shown here for non dedicated programming output DCC systems... Link to item
Replace the loco back onto the Programming track and alter its address number to whatever you wish it to become (avoiding address 3). Replace the loco back onto the main line and manually enter its chosen address manually. Not from any previously installed library. Assuming it moves correctly on its new address, check lights etc are working. Of they are the wrong way around - red when moving forward white at rear. Replace the loco back onto the programming track and if possible read the value set currently in CV29. Then add 1 to whatever was read. e.g. if you read 6 make CV29 value 7. If your system cannot read CV values then just make CV29 value 7 and see what happens when loco is returned back onto the main lines.

Only once you have each loco operating my manually entering its address number should you proceed to alter the library settings for each loco. I would carry out a console reset with the track feed wires disconnected from the terminals of the console all the while the reset is being undertaken, then nothing outside of the console can be effected! Either using the manual instructions 1.3 or 3.5 as far as I can see. https://www.roco.cc/doc/an/1/en/10810_multimaus_en_200614.pdf
[Image << Click the Icon to go to my website
Broken? It was working correctly when I left it.

FergusK
Posts: 21
Joined: Thu May 26, 2016 11:09 am

Re: CV settings/loco not responding

Postby FergusK » Fri Jul 05, 2019 10:00 pm

Thanks very much Flashbang - all running fine now, I'll get around to the headlights soon!
Ferg


Return to “DCC Forum”

Who is online

Users browsing this forum: No registered users and 1 guest