ECoS Controller and ZTC Accessory Decoders

Post all your DCC only problems, solutions and discoverys here.
brammie
Posts: 122
Joined: Fri Aug 17, 2018 7:15 am

ECoS Controller and ZTC Accessory Decoders

Postby brammie » Sun Jun 16, 2019 12:50 pm

As part of the (prolonged) recovery program for my Clackwick Layout, I finally got around to putting the four ZTC-304 Accessory Decoders under the control of my ECoS console. These had previously governed the operation of fourteen sets of points from the ZTC 505 Controller - until it expired. No hardware work was necessary for this new arrangement as everything was in place and connected to the mainline track. In order to recover the points to working state all that needed to be done was explained in the ECoS instructions for Switching Accessories. I loaded point No 1, and it worked! Loading of the remaining sets of points followed quickly. I sat back to admire my handiwork and then noticed that in several cases the EcoS screen indication of point position did not match that on my own console layout "map" - which was hard-wired. OK, I probably loaded the point to the ECoS controller with it set in the wrong position. Delete the offending points from ECoS, set the point positions (by hand) to match the ECoS motif position, then reload each offending point. No difference - after the first operation! I suspect that the anomaly may have something to do with what the ECoS saw when it first met with each point. As far as reprogramming the Accessory Decoders is concerned, there is not a lot I can do since the old ZTC 505 is pretty well dead, and I am stumped for ideas regarding the ECoS. Any help would be greatly appreciated.

brammie
Posts: 122
Joined: Fri Aug 17, 2018 7:15 am

Re: ECoS Controller and ZTC Accessory Decoders

Postby brammie » Sun Jun 16, 2019 6:45 pm

Browsing through the ZTC Decoder Manual this evening it would appear that switching over the point motor outputs at the ZTC-304 might well do the trick . Report to follow.

brammie
Posts: 122
Joined: Fri Aug 17, 2018 7:15 am

Re: ECoS Controller and ZTC Accessory Decoders

Postby brammie » Sun Jun 16, 2019 7:10 pm

Job done. Put the failure to spot the solution earlier down to my advancing years.


Return to “DCC Forum”

Who is online

Users browsing this forum: No registered users and 4 guests